My Oracle Support Banner

Application Blocked by Java Security: Security Warning: Your Security Settings Have Blocked a Self-Signed Application from Running with JRE 1.8.0_20 or Above (Doc ID 2074406.1)

Last updated on MAY 08, 2020

Applies to:

Oracle Forms - Version 11.1.2.2.0 and later
Java SE JDK and JRE - Version 8 and later
Information in this document applies to any platform.

Symptoms

When running a Forms application with custom jar file or files that have been signed with a self-signed certificate the following Security Warning occurs:

FIGURE 1

Click on the "More Information" link and you will be taken to a web page discussing the security settings of your JRE.

The JRE Security Tab indicates the issue occurred because a certificate from a Trusted Certificate Authority (CA) was not used to sign the Jar Files:

FIGURE 2

 

Changes

 Any number of changes could cause this. Changes could be:

1.  Upgrading to a higher JRE version.

2.  Testing a newly signed custom jar files such as signed jacob.jar, jar files containing icons, or jar files containing other custom java code.

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.