Salesforce is disabling TLS 1.0. How can SOA Suite be configured to connect to Salesforce using TLS 1.1 or TLS 1.2? (Doc ID 2112308.1)

Last updated on AUGUST 25, 2017

Applies to:

Oracle SOA Suite - Version 11.1.1.7.8 to 11.1.1.7.8 [Release 11gR1]
Oracle SOA Suite - Version 12.1.3.0.0 and later
Information in this document applies to any platform.

Symptoms

Salesforce will be disabling TSL1.0 protocol for inbound/outbound API & application connections during first quarter of calendar 2016.  See: https://help.salesforce.com/apex/HTViewSolution?id=000221207

When attempting to connect using TLS 1.1 or TLS 1.2, the following error is seen:


RUNTIME ERROR:

javax.net.ssl.SSLHandshakeException: Received fatal alert: handshake_failure


DESIGNTIME ERROR:

"This version of the client is no longer supported"
-or-
"UNSUPPORTED_CLIENT"

 

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms