OPSS - Getting JPS-00027 and ORA-30036 while running migrateSecurityStore (Doc ID 2112993.1)

Last updated on MAY 05, 2016

Applies to:

Oracle Platform Security for Java - Version 11.1.1.9.0 and later
Information in this document applies to any platform.

Symptoms

 When running migrateSecurityStore to export policies, getting the next error

wls:/offline> migrateSecurityStore (type="appPolicies", src="destinationContext", dst="sourceContext", configFile="...../user_projects/domains/Domain/config/fmwconfig/jps-config-tomigration.xml", srcApp="appName", dstApp="appName", overWrite="true")
Mar 01, 2016 9:13:26 PM oracle.security.jps.internal.common.util.JpsCommonUtil initPolicyProvider
INFO: Initializing OPSS Java Policy Provider.
Mar 01, 2016 9:13:35 PM oracle.security.audit.Auditor init
WARNING: IAU:IAU-6012: Unable to determine the audit log directory. No log directory specified.
Mar 01, 2016 9:13:35 PM oracle.security.jps.util.JpsUtil disableAudit
INFO: JpsUtil: isAuditDisabled set to true
Mar 01, 2016 9:13:35 PM oracle.security.jps.internal.audit.AuditServiceImpl validateLogPossible
WARNING: No audit log directory is set. Cannot perform audit operations for component JPS.
WLS ManagedService is not up running. Fall back to use system properties for configuration.
Mar 01, 2016 9:13:36 PM oracle.security.jps.internal.common.util.JpsCommonUtil initPolicyProvider
INFO: OPSS Java Policy Provider initialized.
Mar 01, 2016 9:13:36 PM oracle.security.jps.internal.common.util.JpsCommonUtil initPolicyProvider
INFO: OPSS Java Policy Provider is set as the system-wide Policy object.
Mar 01, 2016 9:13:37 PM oracle.security.jps.internal.tools.utility.JpsUtilMigrationPolicyImpl migrateAppPolicyData
INFO: Migration of Application Policies OracleIdentityManager in progress.....

Command FAILED, Reason: JPS-00027: There was an internal error: java.sql.BatchUpdateException: ORA-30036: unable to extend segment by 8 in undo tablespace 'UNDOTBS'


Traceback (innermost last):
 File "", line 1, in ?
 File "/pkgmnt/IDM/mw/oracle_common/common/wlst/jpsWlstCmd.py", line 983, in migrateSecurityStore
 File "/pkgmnt/IDM/mw/oracle_common/common/wlst/jpsWlstCmd.py", line 950, in migrateSecurityStoreImpl

  at oracle.security.jps.internal.policystore.rdbms.JpsDBDataManager.handleDatabaseException(JpsDBDataManager.java:2132)
  at oracle.security.jps.internal.policystore.rdbms.JpsDBDataManager.processJPAException(JpsDBDataManager.java:2687)
  at oracle.security.jps.internal.policystore.rdbms.JpsDBDataManager.deleteJpsPolicySubtreeByDnInDoAs(JpsDBDataManager.java:3237)
  at oracle.security.jps.internal.policystore.rdbms.JpsDBDataManager.deleteJpsPolicySubtreeByDn(JpsDBDataManager.java:3175)
  at oracle.security.jps.internal.policystore.entitymanager.impl.ApplicationManagerImpl.deleteApplication(ApplicationManagerImpl.java:461)
  at oracle.security.jps.internal.policystore.ldap.LdapPolicyStore.unsync_deleteApplicationPolicy(LdapPolicyStore.java:1191)
...

oracle.security.jps.service.policystore.PolicyStoreConnectivityException: oracle.security.jps.service.policystore.PolicyStoreConnectivityException: JPS-00027: There was an internal error: java.sql.BatchUpdateException: ORA-30036: unable to extend segment by 8 in undo tablespace 'UNDOTBS'

 

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms