"IO Error: No appropriate protocol" When Trying to Connect to Oracle Database 12.1 with TLSv1.1 and TLSv1.2 Protocols (Doc ID 2122800.1)

Last updated on JUNE 12, 2017

Applies to:

JDBC - Version 12.1.0.2.0 to 12.1.0.2.0 [Release 12.1]
Information in this document applies to any platform.

Symptoms

JDBC Thin driver fails with "java.sql.SQLRecoverableException: IO Error: No appropriate protocol" when trying to connect to Oracle database with TLSv1.1 and TLSv1.2 protocols.

Changes

Affects customers using JDBC Thin driver for connections using TLSv1.1 and TLSv1.2 protocols.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms