My Oracle Support Banner

Logo Image (Static Images) not Displayed in the Application (Doc ID 2131668.1)

Last updated on FEBRUARY 18, 2019

Applies to:

Oracle Application Express (APEX) - Version 5.0.3 and later
Oracle Cloud Infrastructure - Database Service - Version N/A and later
Oracle Database Exadata Express Cloud Service - Version N/A and later
Oracle Database Exadata Cloud Machine - Version N/A and later
Oracle Database Cloud Exadata Service - Version N/A and later
Information in this document applies to any platform.

Symptoms

1. APEX is functioning normally except a static image reverenced as #APP_IMAGES# or #WORKSPACE_IMAGES# used for a LOGO is not displaying.

2. A view source of the page shows the image is referenced correctly:

<a href="f?p=300:1:2136137326004" id="uLogo"><img src="test/r/300/files/static/v9Y/My_Logo.gif" width="450" height="70" alt="Company Logo R3" /></a>

 Where:
a. test is your workspace name.
b. 300 is your application ID.
c. r is the new path alias required for APEX 5.0.

3.  Trying to reference the image directly fails with a 404 error:

http://<DOMAINNAME>:<PORT>/ords/test/r/300/files/static/v9Y/My_Logo.gif

4. The ORDS log file shows an error similar to the following:

 

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.