DDMException and Unable to find required dependency" When Upgrading AD Connector From 9.1.1.7.4 To 11.1.1.5 Fails On The Last Step In UI (Doc ID 2131674.1)

Last updated on MAY 03, 2016

Applies to:

Identity Manager - Version 11.1.2.0.0 and later
Information in this document applies to any platform.

Goal

Using OIM 11.1.2.0 BP04 and upgrading AD connector from 9.1.1.7.4 to 11.1.1.5 using the wizard mode, it is failing with UI error "Contact system administrator" and following error being logged in the OIM managed server logs during the upgrade attempt:

----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

 ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------


Steps to reproduce the issue:
---------------------------------
1. AD connector 9.1.1.7.4 is installed.
2. OIM 11g R2 with BP04 is installed.
3. Download the AD connector 11.1.1.5
4. Follow the documentation for connector upgrade procedure. section : 6.8.5.2
http://docs.oracle.com/cd/E21764_01/doc.1111/e14308/conn_mgmt.htm#CIHDGCGC
5. After section : 6.8.5.2 step 5.p On the Step 13: after Selecting Connector Objects to Be Upgraded page.
6. click 'upgrade' - returns system error.
7. check the OIM diagnostic logs for the stack trace on the error

Solution

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms