NullPointerException In OSB KerberosAuthenticator After Upgrading To JDK 1.7.0_80. (Doc ID 2149098.1)

Last updated on JUNE 14, 2016

Applies to:

Oracle Web Services Manager - Version 11.1.1.7.0 and later
Information in this document applies to any platform.

Symptoms

PROBLEM DESCRIPTION
--------------------

An OSB Proxy is secured using the OWSM policy "oracle/wss11_kerberos_token_with_message_protection_basic128_service_policy" in FMW 11.1.1.7. Accessing the Proxy works fine under JDK 1.7.0_21 but under JDK 1.7.0_80 it raises a NullPointerException.
Setting "-Dsun.security.krb5.debug=true" and comparing the output shows the following output lines are missing from JDK.1.7.0_80.


WHAT IS WORKING
---------------
Accessing the Proxy works fine under JDK 1.7.0_21

ENVIRONMENT
------------
OSB 11.1.1.7, JDK 1.7.0_80
OS: Microsoft Windows x64 (64-bit)
OSB/OWSM

STEPS
------
Upgrade JDK version to JDK 1.7.0_80.
Try to access the Proxy as used to work when JDK 1.7.0_21 was used.
Observer the NULLPointerException
 

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms