Installing DB 11.1.0.7.24 Patch 22290164 on a Web Tier 11.1.1.7 on Linux x86-64 Fails Due to Missing Lib32 Files (Doc ID 2169982.1)

Last updated on AUGUST 30, 2016

Applies to:

Oracle Fusion Middleware - Version 11.1.1.7.0 to 11.1.1.7.0 [Release Oracle11g]
Linux x86-64

Symptoms

Over a Web Tier 11.1.1.7.0 version and while attempting to install <Patch:22290164>, the following error occurs on Linux x86-64:

ERROR

Oracle Interim Patch Installer version 11.1.0.10.3
Copyright (c) 2013, Oracle Corporation. All rights reserved.

Oracle Home : /refresh/oracle/fmw11g/Oracle_WT1
Central Inventory : /refresh/64bit/app/oraInventory
from : /refresh/oracle/fmw11g/Oracle_WT1/oraInst.loc
OPatch version : 11.1.0.10.3
OUI version : 11.1.0.9.0
Log file location : /refresh/oracle/fmw11g/Oracle_WT1/cfgtoollogs/opatch/22290164_Jun_21_2016_11_16_03/apply2016-06-21_11-16-03AM_1.log

OPatch detects the Middleware Home as "/refresh/oracle/fmw11g"

Applying interim patch '22290164' to OH '/refresh/oracle/fmw11g/Oracle_WT1'
Verifying environment and performing prerequisite checks...
(...)
ArchiveAction: Destination File "/refresh/oracle/fmw11g/Oracle_WT1/lib32/libxml11.a" does not exists or is not writeable
'oracle.xdk.rsf, 11.1.0.7.0': Cannot update file '/refresh/oracle/fmw11g/Oracle_WT1/libxml11.a' with '/lpxm.o'
ArchiveAction: Destination File "/refresh/oracle/fmw11g/Oracle_WT1/lib32/libclient11.a" does not exists or is not writeable
'oracle.rdbms.rsf, 11.1.0.7.0': Cannot update file '/refresh/oracle/fmw11g/Oracle_WT1/libclient11.a' with '/kpuzln.o'
ArchiveAction: Destination File "/refresh/oracle/fmw11g/Oracle_WT1/lib32/libclient11.a" does not exists or is not writeable
'oracle.rdbms.rsf, 11.1.0.7.0': Cannot update file '/refresh/oracle/fmw11g/Oracle_WT1/libclient11.a' with '/kpuini.o'

Log file location: /refresh/oracle/fmw11g/Oracle_WT1/cfgtoollogs/opatch/22290164_Jun_21_2016_11_16_03/apply2016-06-21_11-16-03AM_1.log

Recommended actions: This patch requires some components to be installed in the home. Either the Oracle Home doesn't have the components or this patch is not suitable for this Oracle Home.

OPatch failed with error code 39




BUSINESS IMPACT

Due to the above errors, it is not possible to be installed the CPU <Patch 22290164> as per Critical Patch Update program. Oracle Fusion Middleware homes require a special FMW-Only 11.1.0.7.24 to be applied to update the Oracle Client 11.1.0.7 files that are installed and need security updates. In some cases, these files need updates for non-security issues, depending if you are using the Oracle Client tools installed.


Reference:
<Note:1073776.1> - Steps to Maintain Oracle Fusion Middleware 11g Release 1 (11.1.1) -> Section: Oracle Database 11.1.0.7.xx PSUs

 

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms