My Oracle Support Banner

Unable to negotiate an acceptable SSL cipher suite with a new transactional web server, 'javax.net.ssl.SSLException: java.lang.ArrayIndexOutOfBoundsException: 64' (Doc ID 2171917.1)

Last updated on MAY 01, 2019

Applies to:

Oracle Java CAPS - Version 5.1.3 and later
Information in this document applies to any platform.

Goal

Unable to negotiate an acceptable SSL cipher suite with a new transactional web server.

When attempting to connect from JCAPS 5.1.3 RU4 using the HTTPS eWay to a new transactional web server, the following error is seen:


The transactional web server was recently switched to use RHEL/Apache and has changed it negotiable cipher suites from:


Q1. Which cipher suites are supported by JCAPS 5.1.3 RU4 running against Java HotSpot(TM) 64-Bit Server VM version 1.5.0_10-b03 running in mixed mode (64bit) on a Solaris 10 (SunOS phie01 5.10 Generic_150400-20 sun4u sparc SUNW,Sun-Fire-V890)?
Q2. Where do you configure the list of acceptable HTTPS client eWay cipher suites?
 

Solution

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Goal
Solution


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.