My Oracle Support Banner

OES11g - Unable distribute policies observing policy store version not compatible having OES Client in remote server (Doc ID 2180473.1)

Last updated on SEPTEMBER 13, 2018

Applies to:

Oracle Entitlements Server - Version 11.1.2.3.0 and later
Information in this document applies to any platform.

Symptoms

After create OES Weblogic SM non-controlled on JRF:

./config.sh -onJRF -smConfigId wls_sm -prpFileName $OES_Client/oessm/SMConfigTool/smconfig_jrf.prp -serverLocation $Middleware_Home/wlserver_10.3

Unable retrieve policies, observing "policy store version not compatible"

Oracle.security.jps.service.policystore. PolicyStoreIncompatibleVersionException
JPS-06100: Policy Store version 11.1.1.9.0 and Oracle Platform Security Services
version 11.1.1.6.0 are not compatible.

Having OES Admin Server and OES Client in different machines

The error "policy store version not compatible" indicates these are different versions no compatible

Policy store version is      => 11.1.1.9.0
OPSS version version  is  => 11.1.1.6.0

This information is coming from

1-Checking OPSS version following
How To Determine The Full OPSS Version  In a WLS Environment (Doc ID 1916029.1)
Seeing => Oracle-Label: ENTSEC_11.1.1.6.0

2-Checking Schema version
Select attrval from jps_attrs where attrname = 'orclProductVersion' and rownum = 1:
Seeing => 11.1.1.9.0

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.