ORA-00001: Unique Constraint Error Upgrading OIM Objects with PSA Tool (Doc ID 2208114.1)

Last updated on MARCH 08, 2017

Applies to:

Identity Manager - Version 11.1.2.1.0 and later
Information in this document applies to any platform.

Symptoms

While trying to upgrade the OIM schema, the following error is returned in the log

--DESCRIPTION: The script is to update the app instance names for gtc resources after app_instances are created.
--It should be placed after the app_instane creation in the upgrade script.

declare

begin
update (select app_instance_name, app_instance_display_name, obj_key, obj_name
from app_instance, obj where object_key=obj_key and
obj_name like '%\_GTC' escape '\')
set app_instance_name=obj_name, app_instance_display_name=obj_name;

commit;
end;

]]
[2016-11-22T10:50:09.460-06:00] [OIM] [NOTIFICATION] [] [upgrade.OIM.OIM1] [tid: 13] [ecid: 0000LYCwPlB4Usp5sRs1yX1OD7Ns000004,0] Enetering in Exception block to exclude some error codes
[2016-11-22T10:50:09.462-06:00] [OIM] [INCIDENT_ERROR] [UPGCMP-00925] [upgrade.OIM.OIM1] [tid: 13] [ecid: 0000LYCwPlB4Usp5sRs1yX1OD7Ns000004,0] An unknown error occured [{0}]
[2016-11-22T10:50:09.462-06:00] [OIM] [INCIDENT_ERROR] [] [upgrade.OIM.OIM1] [tid: 13] [ecid: 0000LYCwPlB4Usp5sRs1yX1OD7Ns000004,0] Cause: Unknown
[2016-11-22T10:50:09.462-06:00] [OIM] [INCIDENT_ERROR] [] [upgrade.OIM.OIM1] [tid: 13] [ecid: 0000LYCwPlB4Usp5sRs1yX1OD7Ns000004,0] Action: See the secondary error message in the log file for the cause of the failure.
[2016-11-22T10:50:09.462-06:00] [OIM] [INCIDENT_ERROR] [] [upgrade.OIM.OIM1] [tid: 13] [ecid: 0000LYCwPlB4Usp5sRs1yX1OD7Ns000004,0] [[
oracle.iam.oimupgrade.exceptions.OIMUpgradeException: SQL Exception in running Upgrade Scripts
at oracle.iam.oimupgrade.onehop.SchemaUpgradeManager.upgrade(SchemaUpgradeManager.java:281)
at oracle.iam.update.plugin.oim.OIMSchemaUpgradePlugin.upgrade(OIMSchemaUpgradePlugin.java:195)
at oracle.ias.update.plugin.Plugin.upgrade(Plugin.java:352)
at oracle.ias.update.plan.PlanStep.upgrade(PlanStep.java:294)
at oracle.ias.update.UpgradeDriver.doUpgrades(UpgradeDriver.java:477)
at oracle.ias.update.gui.UAUpgradeThread.run(UAUpgradeThread.java:42)
Caused by: java.sql.SQLIntegrityConstraintViolationException: ORA-00001: unique constraint (UAT_OIM.UDX_APP_INSTANCE_NAME) violated
ORA-06512: at line 10

at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java:462)
at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java:405)
at oracle.jdbc.driver.T4C8Oall.processError(T4C8Oall.java:931)
at oracle.jdbc.driver.T4CTTIfun.receive(T4CTTIfun.java:481)
at oracle.jdbc.driver.T4CTTIfun.doRPC(T4CTTIfun.java:205)
at oracle.jdbc.driver.T4C8Oall.doOALL(T4C8Oall.java:548)
at oracle.jdbc.driver.T4CStatement.doOall8(T4CStatement.java:202)
at oracle.jdbc.driver.T4CStatement.executeForRows(T4CStatement.java:1110)
at oracle.jdbc.driver.OracleStatement.doExecuteWithTimeout(OracleStatement.java:1488)
at oracle.jdbc.driver.OracleStatement.executeUpdateInternal(OracleStatement.java:2147)
at oracle.jdbc.driver.OracleStatement.executeUpdate(OracleStatement.java:2091)
at oracle.jdbc.driver.OracleStatementWrapper.executeUpdate(OracleStatementWrapper.java:320)
at oracle.iam.oimupgrade.onehop.util.SchemaUpgrader.loadScript(SchemaUpgrader.java:161)
at oracle.iam.oimupgrade.onehop.SchemaUpgradeManager.upgrade(SchemaUpgradeManager.java:216)
at oracle.iam.update.plugin.oim.OIMSchemaUpgradePlugin.upgrade(OIMSchemaUpgradePlugin.java:195)
at oracle.ias.update.plugin.Plugin.upgrade(Plugin.java:352)
at oracle.ias.update.plan.PlanStep.upgrade(PlanStep.java:294)
at oracle.ias.update.UpgradeDriver.doUpgrades(UpgradeDriver.java:476)
at oracle.ias.update.gui.UAUpgradeThread.run(UAUpgradeThread.java:41)

 

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms