OPSS - Getting JpsException: Null Found Searching JpsBase:cn=jpsroot while Upgrading OPSS To PS3 (Doc ID 2221027.1)

Last updated on JANUARY 17, 2017

Applies to:

Oracle Platform Security for Java - Version 11.1.2.3.0 and later
Information in this document applies to any platform.

Symptoms

When attempting to OIM upgrade from 11gR2PS1 to PS3 using upgradeOpss script the following error occurs:

wls:/offline> upgradeOpss(jpsConfig="/app/oracle/Middleware_OAM/user_projects/domains/oam_domain/config/fmwconfig/jps-config.xml",jaznData="/app/oracle/Middleware_OAM/oracle_common/modules/oracle.jps_11.1.1/domain_config/system-jazn-data.xml",jdbcDriver="oracle.jdbc.OracleDriver",url="jdbc:oracle:thin:@host:1521:orcl",user="OIM_OPSS",password="XXXXXXX",upgradeJseStoreType="true")
{upgradeJseStoreType=true, transformData=null, auditStore=null, user=OIM_OPSS, url=jdbc:oracle:thin:@host:1521:orcl, jdbcDriver=oracle.jdbc.OracleDriver, jaznData=/app/oracle/Middleware_OAM/oracle_common/modules/oracle.jps_11.1.1/domain_config/system-jazn-data.xml, jpsConfig=/app/oracle/Middleware_OAM/user_projects/domains/oam_domain/config/fmwconfig/jps-config.xml}
Starting upgrade of opss configuration and security stores.
Jan 3, 2017 11:32:57 AM oracle.security.jps.util.JpsUtil disableAudit
INFO: JpsUtil: isAuditDisabled set to true
Jan 3, 2017 11:32:58 AM oracle.security.jps.util.JpsUtil disableAudit
INFO: JpsUtil: isAuditDisabled set to false
Command FAILED, Reason: Null Found Searching JpsBase:cn=jpsroot
oracle.security.jps.JpsException: Null Found Searching JpsBase:cn=jpsroot
      at oracle.security.jps.internal.common.rdbms.util.JpsDbBootstrapImpl.createRootNode(JpsDbBootstrapImpl.java:1238)
      at oracle.security.jps.internal.common.rdbms.util.JpsDbBootstrapImpl.<init>(JpsDbBootstrapImpl.java:183)
      at oracle.security.jps.upgrade.tools.DBPolicyStoreUpgrade.<init>(DBPolicyStoreUpgrade.java:54)
      at oracle.security.jps.upgrade.tools.utility.Upgrade.upgradeInternal(Upgrade.java:443)
      at oracle.security.jps.upgrade.tools.utility.Upgrade.upgrade(Upgrade.java:342)
...................
Traceback (innermost last):
File "<console>", line 1, in ?
File "/app/oracle/Middleware_OAM/oracle_common/common/wlst/jpsWlstCmd.py", line 1551, in upgradeOpss
oracle.security.jps.JpsException: Null Found Searching JpsBase:cn=jpsroot
      at oracle.security.jps.internal.common.rdbms.util.JpsDbBootstrapImpl.createRootNode(JpsDbBootstrapImpl.java:1238)
      at oracle.security.jps.internal.common.rdbms.util.JpsDbBootstrapImpl.<init>(JpsDbBootstrapImpl.java:183)
      at oracle.security.jps.upgrade.tools.DBPolicyStoreUpgrade.<init>(DBPolicyStoreUpgrade.java:54)
      at oracle.security.jps.upgrade.tools.utility.Upgrade.upgradeInternal(Upgrade.java:443)
      at oracle.security.jps.upgrade.tools.utility.Upgrade.upgrade(Upgrade.java:342)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
...............
oracle.security.jps.JpsException: oracle.security.jps.JpsException: Null Found Searching JpsBase:cn=jpsroot
oracle.security.jps.JpsException: Null Found Searching JpsBase:cn=jpsroot
      at oracle.security.jps.internal.common.rdbms.util.JpsDbBootstrapImpl.createRootNode(JpsDbBootstrapImpl.java:1238)
      at oracle.security.jps.internal.common.rdbms.util.JpsDbBootstrapImpl.<init>(JpsDbBootstrapImpl.java:183)
      at oracle.security.jps.upgrade.tools.DBPolicyStoreUpgrade.<init>(DBPolicyStoreUpgrade.java:54)
     at oracle.security.jps.upgrade.tools.utility.Upgrade.upgradeInternal(Upgrade.java:443)
............

 

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms