Clarification Of Support When Using WLS 9 Security Framework Support In OSB 12.2.1.x

(Doc ID 2231533.1)

Last updated on FEBRUARY 08, 2017

Applies to:

Oracle Service Bus - Version 12.2.1.0.0 and later
Information in this document applies to any platform.

Goal

Is WLS 9 policy framework security supported in 12.2.1.x?

According to OSB 12.2.1.1.0 documentation http://docs.oracle.com/middleware/12211/osb/develop/GUID-F5FA877F-42F9-4405-AD54-6E8A0AD45064.htm#OSBDV1647

"You can use SAML with either the WLS 9 policy framework or with Oracle Web Services Manager. Oracle recommends that you use Oracle Web Services Manager for service security, as described in Securing Oracle Service Bus with Oracle Web Services Manager."

Further in http://docs.oracle.com/middleware/12211/osb/develop/GUID-1CE01E95-8B9B-4369-AAC9-28F4C5B6EF63.htm#OSBDV1681

"Oracle Web Services Manager (OWSM) is the Web Services security mechanism used by Service Bus. All newly created resources, such as business services and proxy services, use OWSM policies for security. WLS 9 policies are deprecated, and cannot be used to configure security for a new Service Bus resource. However, you can import resources already configured with WLS 9 policies into your Service Bus project. You cannot edit or modify these WLS 9policies, but you can replace them with OWSM policies."

 

Solution

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms