Cannot Import Sbconfig.jar From 11.1.1.9 To 12.2.1.1.0 (Doc ID 2231585.1)

Last updated on FEBRUARY 14, 2017

Applies to:

Oracle Service Bus - Version 12.2.1.0.0 and later
Information in this document applies to any platform.

Symptoms

Unable to import an sbconfig.jar that was generated in 11.1.1.9 into Service Bus 12.2.1.1.0.

The error below is seen when attempting the import:

The jar that is being imported is an unsupported version of the product. The version was 11.1.1.9. Supported versions are: 11.2.1.0.0.dev1, 3.0.dev2, 12.2.1.1.0, 12.2.1.0.0, 10.3.1.0, 3.0.dev1, 10.3.0.0, 3.2.dev2, 3.0.0, 3.2.dev1, 11.1.1.2, 11.1.1.3, 10.3.0.0.dev2, 11.1.1.6, 11.1.1.7, 11.1.1.4, 11.1.1.5, 10.3.2.0.dev.2, 10.3.2.0.dev.1, 11.1.1.2.dev.1, 10.3.2.0.dev.3, 11.1.1.2.dev.2, 11.2.1.0.0.dev4, 11.2.1.0.0.dev5, 11.2.1.0.0.dev2, 11.2.1.0.0.dev3, 12.1.3.0.0, 11.2.1.0.0.dev8, 11.2.1.0.0.dev9, 11.2.1.0.0.dev6, 11.2.1.0.0.dev7,

 

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms