OPatch failed with error code 31 Error Messages When Applying Patch (Doc ID 2242045.1)

Last updated on AUGUST 10, 2017

Applies to:

Oracle WebLogic Server - Version 12.1.2.0.0 and later
Information in this document applies to any platform.

Symptoms

While applying <Patch 24904865>: WLS PATCH SET UPDATE 12.2.1.0.170117 the following error message is thrown:

Applying interim patch '24904865' to OH '/weblogics/Oracle/Middleware/wl12c'
Verifying environment and performing prerequisite checks...
Prerequisite check "CheckMinimumOPatchVersion" failed.
The details are:

The OPatch being used has version 13.2.0.0.0 while the following patch(es) require higher versions:
Patch 24904865 requires OPatch version 13.3.0.0.0.
Please download latest OPatch from My Oracle Support.

Log file location: /weblogics/Oracle/Middleware/wl12c/cfgtoollogs/opatch/24904865_Mar_08_2017_10_16_51/apply2017-03-08_10-16-37AM_1.log

Recommended actions: Please download latest OPatch from My Oracle Support by Patch 6880880, release version (as appropriate) and appropriate platform.

OPatch failed with error code 31

 

 

Changes

 

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms