APEX 5.1 Upgrade Fails With ORA-20987: APEX - Can Not Delete Application 8801 (Doc ID 2251449.1)

Last updated on SEPTEMBER 13, 2017

Applies to:

Oracle Application Express (formerly HTML DB) - Version 5.1.0.00.43 and later
Information in this document applies to any platform.

Symptoms

Upgrading to Apex 5.1 after a previous failed upgrade, fails with:

Application Express internal themes

...Installing Theme 1

API Last Extended:20160824
Your Current Version:20160824
This import is compatible with version: 20160824
COMPATIBLE (You should be able to run this import without issues.)
--application/set_environment
APPLICATION 108801 - Theme: Simple Red
--application/delete_application
begin
*
ERROR at line 1:
ORA-20987: APEX - Can not delete application 8801, it is installed in a
different workspace! - Contact your application administrator.
ORA-06512: at "APEX_050100.WWV_FLOW_ERROR", line 1028
ORA-06512: at "APEX_050100.WWV_FLOW_ERROR", line 1395
ORA-06512: at "APEX_050100.WWV_FLOW_API", line 2277
ORA-06512: at line 2

 

Changes

 Attempting to upgrade to 5.1 after a previously failed upgrade.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms