"You must specify the value of {required_multiple_attribute}" Error displayed when Saving an Asset in Contributor UI that has a Value for that Required Multiple Value Attribute.

(Doc ID 2255242.1)

Last updated on AUGUST 08, 2017

Applies to:

Oracle WebCenter Sites - Version 12.2.1.2.0 to 12.2.1.2.0 [Release FatWire]
Information in this document applies to any platform.

Symptoms

"You must specify the value of {required_attribute}" Error displayed when Saving an Asset in Contributor UI that has a Value for that Required Attribute.

What is not working:
An asset that has a required attribute of type asset which is multiple valued.
- In the flex definition, the attribute is required.
- When saving the asset, even if a value is included in the required attribute, the UI displays "You must specify the value of {required_attribute}" and does not save the asset.

What is working:
- If the attribute is changed to not required in the definition, it will save without a problem.
- If the attribute is changed to single valued , it will save without a problem.
- If the description of the multiple valued attribute is blank, then it will save without a problem.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms