Entries In Service Tables Are Incorrect After Updating Domain Configuration In WebLogic Console (Doc ID 2262042.1)

Last updated on MAY 09, 2017

Applies to:

Oracle SOA Suite - Version 12.2.1.2.0 and later
Information in this document applies to any platform.

Goal

Entries in Service Tables are incorrect after updating domain configuration in Weblogic console

When creating or modifying the domain configuration for a BPM domain, the DEV_STB tables are often automatically updated with the service URLs for URN.

However the DEV_STB.SERVICETABLE contains incorrect values for all SSL ports and needs to be manually edited in the database.

After saving the domain configuration this can be seen for example for urn:oracle:fmw.soa:t3 as below:

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<endpoint xmlns="http://xmlns.oracle.com/servicetable/endpoint">
<service-id>urn:oracle:fmw.soa:t3</service-id>
<service-type>fmw.soa:t3</service-type>
<connection>
<t3>
<urls>
<default>t3://localhost:30011</default>
<plain>t3://localhost:30011</plain>
<ssl>t3s://localhost:30011</ssl> <-- THIS IS THE WRONG PORT -->
<cluster>cluster:t3://example.net</cluster>
</urls>
</t3>
</connection>
</endpoint>

instead of being like this:

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<endpoint xmlns="http://xmlns.oracle.com/servicetable/endpoint">
<service-id>urn:oracle:fmw.soa:t3</service-id>
<service-type>fmw.soa:t3</service-type>
<connection>
<t3>
<urls>
<default>t3://localhost:30011</default>
<plain>t3://localhost:30011</plain>
<ssl>t3s://localhost:30013</ssl> <-- THIS IS THE CORRECT PORT -->
<cluster>cluster:t3://example.net</cluster>
</urls>
</t3>
</connection>
</endpoint>

 

Solution

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms