My Oracle Support Banner

ODI 12.2 Repositories are Created as the Wrong Version by the RCU (Doc ID 2263411.1)

Last updated on MAY 16, 2017

Applies to:

Oracle Data Integrator - Version 12.2.1.0.0 and later
Information in this document applies to any platform.

Symptoms

The Oracle Data Integrator (ODI) 12.2.1.2.6 Repository Creation Utility (RCU) was executed to create Repositories with prefix "DEV". No warnings and/or error message are observed during the RCU execution.

However, when using ODI 12.2.1.2.6 Studio to connect to the above-created Repositories, the operation fails, and following error message is received:

oracle.odi.core.config.MasterRepositoryVersionMismatchException: ODI-10179: Client requires a repository with version 05.02.02.05 but the repository version found is 05.01.01.06.
  at oracle.odi.core.repository.Repository.getMasterRepository(Repository.java:135)
  at oracle.odi.core.OdiInstance.createMasterRepository(OdiInstance.java:601)
  at oracle.odi.core.OdiInstance.(OdiInstance.java:852)
  at oracle.odi.core.OdiInstance.createInstance(OdiInstance.java:719)
  at oracle.odi.core.OdiInstance.createInstance(OdiInstance.java:667)
  at oracle.odi.core.OdiInstance.createInstance(OdiInstance.java:646)

Changes

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.