Coherence/Weblogic Servers Fail to Start in Production Mode (Doc ID 2269368.1)

Last updated on JULY 24, 2017

Applies to:

Oracle Coherence - Version 12.1.2.0.0 and later
Information in this document applies to any platform.

Symptoms

On : 12.2.1.0.0 version, WLS-Config (non-component)

Weblogic domain for service bus was installed in development mode and unable to start the managed servers after changing manually to production mode from weblogic console. Below error is thrown in the logs

ERROR
-----------------------

(thread=[STANDBY] ExecuteThread: '3' for queue: 'weblogic.kernel.Default (self-tuning)', member=n/a): Error while starting cluster: java.lang.RuntimeException: Failed to start Service "Cluster" (ServiceState=SERVICE_STOPPED, STATE_JOINING)
at com.tangosol.coherence.component.util.daemon.queueProcessor.Service.start(Service.CDB:38)
at com.tangosol.coherence.component.util.daemon.queueProcessor.service.Grid.start(Grid.CDB:6)
at com.tangosol.coherence.component.net.Cluster.startSystemServices(Cluster.CDB:4)
at com.tangosol.coherence.component.net.Cluster.onStart(Cluster.CDB:53)
at com.tangosol.coherence.component.net.Cluster.start(Cluster.CDB:12)
at com.tangosol.coherence.component.util.SafeCluster.startCluster(SafeCluster.CDB:4)
at com.tangosol.coherence.component.util.SafeCluster.restartCluster(SafeCluster.CDB:10)
at com.tangosol.coherence.component.util.SafeCluster.ensureRunningCluster(SafeCluster.CDB:32)
at com.tangosol.coherence.component.util.SafeCluster.getRunningCluster(SafeCluster.CDB:7)
at com.tangosol.coherence.component.util.SafeCluster.start(SafeCluster.CDB:5)
at com.tangosol.net.CacheFactory.ensureCluster(CacheFactory.java:537)

 

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms