WLS 12.2.1.2.0 TLSv1.2-based Connection To AD Fails with error "javax.net.ssl.SSLHandshakeException: Server chose TLSv1.1, but that protocol version is not enabled or not supported by the client." (Doc ID 2273071.1)

Last updated on JUNE 02, 2017

Applies to:

Oracle WebLogic Server - Version 12.2.1.2.0 and later
Information in this document applies to any platform.

Symptoms

Active Directory (AD) has TLS 1.2 protocol enabled and Weblogic is connecting to AD over SSL.

WLS 10.3.6(running on JDK 1.7.0_121) is able to successfully connect to AD using TLS 1.2 protocol.

However, AD provider configured on WLS 12.2.1.2.0(running on JDK 1.8.0_121) fails to connect to the same AD with the following error :

 

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms