After Upgrade From ODI 11g To 12.2.1.1.0 In Compatibility Mode, The _RMS Reusable Mappings Generate Incorrect Code

(Doc ID 2273310.1)

Last updated on JANUARY 19, 2018

Applies to:

Oracle Data Integrator - Version 12.2.1.1.0 to 12.2.1.2.0 Beta [Release 12c]
Information in this document applies to any platform.

Symptoms

After having successfully upgraded the Oracle Data Integrator (ODI) Repositories from 11g to 12.2.1.1 in compatibility mode, the execution of any Mapping that contains Reusable Mappings fails.

A closer look at the Reusable Mappings post-upgrade, it could be observed that the Reusable Mappings type _RMS "uses" contains the incorrect code, while the Reusable Mappings type _RMT are correct.

If changing the final Mapping to use instead the _RMT Reusable Mappings, the execution succeeds. This change however should not be done manually!

Steps to reproduce the behavior:

     == or ==

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms