OVD 11g syncovdconfig.pl Fails with: com.octetstring.vde.config.VersionException: Document Versions Not Equal| |true|1| (Doc ID 2276009.1)

Last updated on JUNE 13, 2017

Applies to:

Oracle Virtual Directory - Version 11.1.1.0 and later
Information in this document applies to any platform.

Symptoms

Oracle Virtual Directory (OVD) 11g servers with same OVD versions, patches, and JDK versions.

At one point, manually edited adapters in adapters.os_xml file in one of the nodes, due to Oracle Directory Services Manager (ODSM) not being available. No other configuration files were touched.

Since then, synchronizing all OVD configuration using syncovdconfig.pl returns error:


If sync'ng individual config files at a time, it may fail for some and not others.

Tried backing up and manually deleting the failing config files, e.g., adapters.os_xml and server.os_xml, but the same error continues.

Restarting the entire stack does not help.

Changes

 

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms