How to Implement Deployment Rule Set to Avoid Java Related Security Warnings (Doc ID 2282967.1)

Last updated on AUGUST 29, 2017

Applies to:

Java SE JDK and JRE - Version 7 and later
Oracle Forms - Version 11.1.2.2.0 and later
Information in this document applies to any platform.

Goal

Various types of Java Security Warnings/Jar File issues may occur when using unsigned jar files or older versions of the JRE with Forms and your browsers.  Some examples are:

1. Unsigned jar files containing iconic images may illicit the following Security Warning:

"Block potentially unsafe components from being run?

2. If using an older version of the JRE, your browser may issue this message:

Java Update Needed

  Your Java version is out of date

 

Solution

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms