Error "weblogic.Server isn't supported by JDK versions less than 1.8" When Using Weblogic 12.2.1.2 With JDK 1.7.0_99+

(Doc ID 2293005.1)

Last updated on OCTOBER 15, 2017

Applies to:

Oracle WebLogic Server - Version 12.2.1.2.0 to 12.2.1.2.0 [Release 12c]
Information in this document applies to any platform.

Goal

Is JDK 7 supported by Weblogic 12.2.1.2?

The issue is that starting the Admin Console with JDK 1.7.0_141 gives the following error:

weblogic.Server isn't supported by JDK versions less than 1.8

 

Solution

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms