My Oracle Support Banner

FMW 인스톨러 에서 Prerequisite 점검시에 Warning : ".el6-i686; Not found. Failed" 메세지 발생 - 왜 32-bit 패키지가 필요한가 ? (Doc ID 2296075.1)

Last updated on JULY 09, 2019

적용 대상:

Oracle Fusion Middleware - 버전 11.1.1.2.0 to 12.2.1.0.0 [릴리즈 Oracle11g to 12c]
Oracle HTTP Server - 버전 11.1.1.2.0 to 12.2.1.0.0 [릴리즈 Oracle11g to 12c]
이 문서의 내용은 모든 플랫폼에 적용됩니다.

증상

이 문제는 어떤 버전의 어떤 Oracle Fusion Middleware (FMW) 제품에서도 발생할 수 있습니다. 다만 다른 점은 각 Linux 버전에 따라 다른 패키지를 요구한다는 점입니다. 

다음 에러들은 Oracle Linux 6 에 OHS 12.2.1 설치도중 Prerequisite Checks 과정에서 발생합니다 :

Checking for compat-libstdc++-33-3.2.3-69.el6-x86_64; found compat-libstdc++-33-3.2.3-69.el6-x86_64. Passed
Checking for compat-libstdc++-33-3.2.3-69.el6-i686; Not found. Failed <<<<
Checking for libgcc-4.4.4-13.el6-i686; Not found. Failed <<<<
Checking for libgcc-4.4.4-13.el6-x86_64; found libgcc-4.4.7-16.el6-x86_64. Passed
Checking for libstdc++-4.4.4-13.el6-x86_64; found libstdc++-4.4.7-16.el6-x86_64. Passed
Checking for libstdc++-4.4.4-13.el6-i686; Not found. Failed <<<<
Checking for libstdc++-devel-4.4.4-13.el6-x86_64; found libstdc++-devel-4.4.7-16.el6-x86_64. Passed

 

만일 위 에러를 해결하기 위해 이 패키지 설치 요청을 SKIP 하면 다른 에러들이 발생하게 됩니다 :


# yum install compat-libstdc++-33-3.2.3-69.el6-i686
"No package available".

or

# yum install compat-libstdc++-33-3.2.3-69.el6.i686
Error: Protected multilib versions: libstdc++-4.4.4-13.el6.i686 != libstdc++-4.4.6-4.el6.x86_64
# yum install libgcc-4.4.4-13.el6.i686
Error: Protected multilib versions: libgcc-4.4.4-13.el6.i686 != libgcc-4.4.6-4.el6.x86_64
# yum install libstdc++-4.4.4-13.el6.i686
Error: Protected multilib versions: libstdc++-4.4.4-13.el6.i686 != libstdc++-4.4.6-4.el6.x86_64

 

원인

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.