MAF 2.3.1 Extension Installation Fails For JDeveloper 12.2.1.0.0 Version From OTN

(Doc ID 2302094.1)

Last updated on SEPTEMBER 04, 2017

Applies to:

Oracle JDeveloper - Version 12.2.1.0.0 to 12.2.1.0.0 [Release 12c]
Information in this document applies to any platform.

Symptoms

When downloading the Oracle JDeveloper 12c (12.2.1.0.0) October 2015 from OTN:

Instead of getting JDeveloper version 12.2.1.0.42.151011.0031 (151011 = 2015/Oct/11)
it is actually delivering a newer JDeveloper version 12.2.1.0.42.170105.1157 (170105 = 2017/Jan/05)

This is causing the MAF 2.3.1 extension installation to fail as it does a compatibility check with the JDeveloper version.

MAF 2.3.1 is designed to work with oracle.studio (min= 12.2.1.0.42.151011.0031 , max=12.2.1.0.42.160604.0120 ) as mentioned here.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms