Applet Fails to Load with AbstractMethodError in TrustManager.checkServerTrusted After Updating the Version of Java

(Doc ID 2312853.1)

Last updated on OCTOBER 01, 2017

Applies to:

Java SE JDK and JRE - Version 8 and later
Information in this document applies to any platform.

Symptoms

Starting on Java SE 8 Update 102, or Java SE 7 Update 111, an applet which used to run will not run any longer.  This happened when a Deployment Rule Set was being used to invoke the applet and an installation of Java SE 6 was requested as the version to run the applet.

 

Changes

 The JRE was updated from version 8 Update 60 where the applet worked.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms