My Oracle Support Banner

ODI 11.1.1.7 Error "Java version 1.6.0_aa is not supported. The minimum version required is 1.6.0_bb" When Using JDK with Three Digit Build Number (Doc ID 2342540.1)

Last updated on JANUARY 16, 2018

Applies to:

Oracle Data Integrator - Version 11.1.1.7.0 to 11.1.1.7.0 [Release 11gR1]
Information in this document applies to any platform.

Symptoms

After updating a Windows install of Oracle Data Integrator (ODI) Studio 11.1.1.7 to use JDK version 1.6.0_171 (or another three-digit build number), Studio no longer starts. It reports the following message:

java version 1.6.0_17 not supported. The minimum version required is 1.6.0_24

Noted that the "unsupported" version in the error (i.g. "1.6.0_17") is actually a truncated string from the actual version attempted (i.g. "1.6.0_171").

When Studio is reconfigured to use a version of Java 6 with a two-digit build, it starts correctly.

Changes

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.