java.lang.UnsupportedOperationException: This class does not support JDK1.5 Error After Upgrade From 1.7.0_161

(Doc ID 2404150.1)

Last updated on MAY 28, 2018

Applies to:

Oracle WebLogic Server - Version 10.3.6 and later
Information in this document applies to any platform.

Symptoms

On : 10.3.6 version, WLS-WebServices

WLS is running in JDK version 1.7.0_161. After upgrading to JDk 1.7.0_171 , client application (which uses wlsfullclient.jar) is seeing the error "java.lang.UnsupportedOperationException: This class does not support JDK1.5".  Log files shows :


The issue can be reproduced at will by simply upgrading the JDK

Due to this issue, JDK upgrade cannot proceed or application will fail.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms