My Oracle Support Banner

Earliest Version Of CEP Supporting JMS2.0 (Doc ID 2406641.1)

Last updated on AUGUST 02, 2018

Applies to:

Oracle Stream Analytics - Version 12.2.1.1.0 and later
Information in this document applies to any platform.

Goal

We are running an Oracle Complex Event Processing 12.2.1.2 server on our FX pipeline, talking to other systems over IBM MQ. Recently we plan to move to new MQ8 library, which requires JMS2.0 library.

However we found that CEP 12.2.1.2 has JMS1.1.4 included in its core lib. Because CEP always load system libraries first, we cannot override the JMS1.1.4 library, and instruct spring-jms to use JMS2.0 library.

Please advise which version of CEP support JMS2.0, or does there exist a patch for our current CEP server to upgrade javax.jms_1.1.4.jar to one of 2.0 version.
 

Solution

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.