BI Publisher Login Performance Issue, Delay in LibOVD Processing. Log WARNING LIBOVD-60024 Connection error: simple bind failed: servername.company.com:<port>

(Doc ID 2418658.1)

Last updated on JULY 06, 2018

Applies to:

Oracle Virtual Directory - Version 11.1.1.9.0 and later
Information in this document applies to any platform.

Symptoms

 Business Intelligence (BI) managed server logs report the following: 

[2018-06-11T01:03:34.926-07:00] [bi_server1] [WARNING] [LIBOVD-60024] [oracle.ods.virtualization.engine.backend.jndi.DefaultAuthenticator] [tid: [ACTIVE].ExecuteThread: '2'
for queue: 'weblogic.kernel.Default (self-tuning)'] [userId: <anonymous>] [ecid: <ECID string>] [APP: bipublisher#11.1.1]
[DSID: <DSID string>] Connection error: simple bind failed: servername.company.com:7032.

[2018-06-11T01:03:34.927-07:00] [bi_server1] [NOTIFICATION] [] [oracle.ods.virtualization.engine.backend.jndi.DefaultAuthenticator] [tid: [ACTIVE].ExecuteThread: '2' for queue:
'weblogic.kernel.Default (self-tuning)'] [userId: <anonymous>] [ecid: <ECID string>] [APP: bipublisher#11.1.1]
[DSID: <DSID string>] Priming the connection pool.ldap://[servername.company.com]:8031


++++++++++++++++++++++ This is where the latency is +++++++++++++++++++++++++++++++++

Previous line logged at 2018-06-11T01:03:34
Next line logged at 2018-06-11T01:04:05

[2018-06-11T01:04:05.403-07:00] [bi_server1] [WARNING] [LIBOVD-60024] [oracle.ods.virtualization.engine.backend.jndi.DefaultAuthenticator] [tid: [ACTIVE].ExecuteThread: '2' for queue: 'weblogic.kernel.Default (self-tuning)'] [userId: <anonymous>] [ecid: <ECID string>] [APP: bipublisher#11.1.1] [DSID: <DSID string>] Connection error: simple bind failed: servername.company.com:8031.

[2018-06-11T01:04:05.404-07:00] [bi_server1] [NOTIFICATION] [LIBOVD-20044] [oracle.ods.virtualization.accesslog] [tid: [ACTIVE].ExecuteThread: '2' for queue: 'weblogic.kernel.Default
(self-tuning)'] [userId: <anonymous>] [ecid: <ECID string>] [APP:bipublisher#11.1.1] [DSID: <DSID string>] conn=5 op=1 RESULT err=2 tag=0 nentries=0 etime=0 dbtime=0 mem=273,838,808/560,463,872


Tried re-ordering providers. No change in behavior.

Tried updating Adapters sequence in adapters.os_xml file; still no change.

The request always goes to Default authenticator first where the delay is caused irrespective of the configuration.

Even tried updating priority of adapters; gave priority 1 for OUDauthenticator, but still the issue continues.

For testing purpose, disabled default authenticator on adapters.os_xml file by setting '<active>false</active>'. After this change, the login is very fast and no performance issue is seen.

Changes

Issue started after configuring new ldap authenticator for BI server, apart from default weblogic authenticator. 

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms