My Oracle Support Banner

Trying To Start WebLogic Components After Completing OID Upgrade From 11.1.1.9 To 12.2.1.3.0 Fails with "Unable to deploy EJB: dipejb.jar from dipejb.jar" Error (Doc ID 2436266.1)

Last updated on AUGUST 23, 2018

Applies to:

Oracle Fusion Middleware - Version 12.2.1.3.0 to 12.2.1.3.0 [Release 12c]
Information in this document applies to any platform.

Symptoms

An OID home was successfully upgraded from 11.1.1.9 to 12.2.1.3.0, but when starting processes after the upgrade the following error occurs:

ERROR
"Unable to deploy EJB: dipejb.jar from dipejb.jar:
There are 5 nested errors:
weblogic.ejb.container.compliance.ComplianceException: In EJB DIPProv, the throws clause for method initialize(java.lang.String,java.lang.String) in the bean class contains exceptions that are NOT in the throws clause of the corresponding local interface method."




Changes

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.