My Oracle Support Banner

SSO Not Working On WebCenter Content As Users Are Prompted To Login Again (Doc ID 2438914.1)

Last updated on OCTOBER 11, 2019

Applies to:

Oracle WebCenter Content - Version 12.2.1.3.0 and later
Information in this document applies to any platform.

Symptoms

ISSUE
-----------------------
Users can logon with SSO, however whether the browser cache is emptied, or not SSO test is executed upon sending a request to WCC, users will be prompted to login.
Traces show clearly that SSO works when the SSOTest is invoked first (IsCookieLoggedIn=1) and that the connection is refused, forcing the user to login, when no Kerberos ticket was obtained before. The error log shows the that the user is anonymous, what is basically also the problem via the WCC URL, when connecting with DIS (SSO).

The request is send via a load balancer (LB)


ERROR
-----------------------


STEPS TO REPLICATE
-----------------------
1. Integrate WCC with SSO.
2. Users are able to log onto WCC via SSO.
3. Whether the browser cache is emptied or not, SSO test is executed upon sending a request to WCC, users will be prompted to login again.


BUSINESS IMPACT
-----------------------
User(s) can logon with SSO when first the LB tests is executed, however when the browser cache is emptied, or not SSO test is executed upon sending a request to WCC, users will be prompted to login.

Changes

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.