My Oracle Support Banner

BAM ICommand Export Function Not Responding (Doc ID 2506396.1)

Last updated on AUGUST 26, 2019

Applies to:

Oracle BAM (Business Activity Monitoring) - Version 11.1.1.9.0 and later
Information in this document applies to any platform.

Symptoms

On : 11.1.1.9.0 version,

ACTUAL BEHAVIOR
---------------
BAM iCommand Export Function not Responding

User is attempting to perform a migration of BAM report folders from UAT to Prod (Both environments are version 11.1.1.9), but unable to perform the export action through use of iCommand.

User is referencing this Oracle documentation: http://docs.oracle.com/cd/E28280_01/dev.1111/e10224/bam_app_icommand.htm#SOASE2336

  Problem Details:
  Loss of functionality - No server-related failure, however this does stall migration to a production environment.

  Sequence of Events -
  1. Navigate to the iCommand location on the UAT environment: <MIDDLEWARE_HOME>\soa\bam\bin\
  2. Run command to export a folder of reports ("AP", for example): icommand -cmd export -name "AP" -type folder -file "C:\u01\BAMExports\AP.xml"
  3. The command prompts for a username, and password. To which user submits the weblogic username and password. After pressing enter, the command seems to stall or not to initialize, with no errors or logging to indicate whether the command is running, or whether the credentials were accepted.

EXPECTED BEHAVIOR
-----------------------
  Expectation - The command should log some status of the execution, and/or export the folder of reports to the specified location. It seems to do neither presently.

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.