My Oracle Support Banner

ODI Upgrade Fails with UPGAST-00224 "database does not contain any schemas" (Doc ID 2547450.1)

Last updated on DECEMBER 01, 2020

Applies to:

Oracle Data Integrator - Version 12.2.1.0.0 and later
Information in this document applies to any platform.

Symptoms

When attempting to upgrade the Oracle Data Integrator (ODI) schemas, the following error seen in the Upgrade Assistant (UA):

The specified database does not contain any schemas for Oracle Data Integrator or the database user lacks privilege to view the schemas.
Cause: The database you have specified does not contain any schemas registered as belonging to the component you are upgrading, or else the current database user lacks privilege to query the contents of the schema version registry.
Action: Verify that the database contains schema entries in schema version registry. If it does not, specify a different database. Verify that the user has DBA privilege. Connect to the database as DBA.

The error is written to the UA log, with the following addition:

Upgrade was canceled by the user.

The database user is confirmed to have DBA privileges on the schema.

Changes

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.