My Oracle Support Banner

Upgrade Question for SAP User Management In OIM 12c With SAP ER 9.x Connector (Doc ID 2566439.1)

Last updated on JULY 21, 2020

Applies to:

Identity Manager Connector - Version 12.2.1.3.0 and later
Information in this document applies to any platform.

Goal

The documentation says:

8.1.2 SAP UM 12c Connector and SAP ER 9.x connector Do Not Work

The ICF-based SAP User Management connector and the legacy SAP ER connector do not work together with Oracle Identity Governance because ICF uses a different class loader for each connector bundle. When both the connectors are installed, the connector bundle that creates the first connection works. When the second bundle tries to create a connection, it tries to register the data provider that is already registered by first bundle. Then, it throws an error, "DestinationDataProvider already registered".
Workaround: To use both the SAP User Management connector and the legacy SAP ER connector, deploy the SAP UM connector in a connector server and deploy the SAP ER connector in Oracle Identity Governance.


Is it possible to upgrade the existing SAP UM connector to 12c and then deploy it on connector server so that it is possible to maintain the SAP ER 9.x connector on OIG as stated in the 8.1.2 section?
 

Solution

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Goal
Solution


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.