My Oracle Support Banner

OPSS 11g: During JDK Hardening - Admin Server Failed To Start With Errors JPS-01050,PKI-02002 (Doc ID 2580179.1)

Last updated on MAY 12, 2021

Applies to:

Oracle Platform Security for Java - Version 11.1.1.6.0 and later
Information in this document applies to any platform.

Symptoms

On : 11.1.1.6.0 version, Java Platform Security

weblogic admin server start is failing with below errors.
.
ERROR
-----------------------

PKI-02002: Unable to open the wallet. Check password.
.Caused By: oracle.security.jps.JpsRuntimeException: JPS-01050: Opening of wallet based credential store failed. Reason java.io.IOException: PKI-02002: Unable to open the wallet. Check password.
Caused By: oracle.security.jps.JpsException: JPS-01050: Opening of wallet based credential store failed. Reason java.io.IOException: PKI-02002: Unable to open the wallet. Check password.
Caused By: oracle.security.jps.service.credstore.CredStoreException: JPS-01050: Opening of wallet based credential store failed. Reason java.io.IOException: PKI-02002: Unable to open the wallet. Check password.

Steps
----------

As part of securing Oracle Retail applications, Following the  JDK hardening for use with retail applications part



BUSINESS IMPACT
-----------------------
The issue has the following business impact:
Due to this issue, users cannot start Admin server

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.