My Oracle Support Banner

Receiving Push-plugin Warning When Trying To Deploy MAF Application To Emulator (Doc ID 2587552.1)

Last updated on MARCH 07, 2021

Applies to:

Mobile Application Framework - Version 2.6.0 and later
Information in this document applies to any platform.

Goal

On MAF 2.6.0 version, receiving push-plugin warning when trying to deploy MAF application to emulator

When deploying a Mobile Application Framework (MAF) application on Android to the emulator the warning about PushPlugin.java using "unchecked or unsafe operations" is shown:

Using Android build tools 27.0.3, SDK tools 26.1.1, JDK 1.8.0_221, JDeveloper 12.2.1.3, Android Platform 27 (Oreo 8.1, Revision 3).

What is the cause and consequences of this message?

Note: same message is shown using MAF 2.6.1

Solution

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.