My Oracle Support Banner

Unable to Load Assets After Upgrade: Missing Custom Class Libraries (Doc ID 2610364.1)

Last updated on NOVEMBER 18, 2019

Applies to:

Oracle WebCenter Sites - Version 12.2.1.0.0 and later
Information in this document applies to any platform.

Symptoms

When attempting to load an asset, the Contributor UI displays "ContentServer Error" in Form mode.

Additionally, if searching for assets then clicking on the asset from search results, a javascript popup displays the following error: 

An exception occurred on the server while executing UI/Data?Asset/AssetMetada: ClassNotFoundException: {custom class}. If problem persists please contact the system administrator.

The sites.log shows shows many classpath-related errors related to custom classes.  One such error could be:

[wcsites_server1] [ERROR] [] [oracle.wcsites.xcelerate.asset] [tid: 106] [userId: ] [APP: sites] [partition-name: DOMAIN] [tenant-name: GLOBAL] Error in ComplexAsset: {custom class}[[
com.openmarket.basic.interfaces.AssetException: {custom class}
at com.openmarket.gator.common.FilterManager.loadFilter(FilterManager.java:85)
at com.openmarket.gator.interfaces.FilterFactory.getFilterInstance(FilterFactory.java:25)
at com.openmarket.gator.flexfilters.FlexFilterInstance.describeDerivedAttributes(FlexFilterInstance.java:292)

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.