My Oracle Support Banner

"ODI-1590: The execution of the script failed" Message is Received when Using "LKM Spark to SQL" with J2EE agent in ODI 12c (Doc ID 2625654.1)

Last updated on AUGUST 18, 2023

Applies to:

Oracle Data Integrator - Version 12.2.1.3.181204 to 12.2.1.4.0 [Release 12c]
Oracle Data Integrator on Marketplace - Version 1.0.2 to 1.1.1
Information in this document applies to any platform.

Symptoms

In Oracle Data Integrator (ODI) 12.2.1.3 or base release ODI 12.2.1.4, a mapping using the Loading Knowledge Module (LKM) titled "LKM SQL to Spark" doesn't work as expected when trying to load data from Hive to Oracle over the Spark technology using J2EE Agent.

The LKM fails at step "Deploy ODI jars" with the error as follows:

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.