My Oracle Support Banner

ODI 12c Readiness Check for Domain Based Upgrade throws "Plugin ODI.ODI1 disabled, isUpgradeRequired returned exception" (Doc ID 2632497.1)

Last updated on JANUARY 31, 2020

Applies to:

Oracle Data Integrator - Version 12.1.3.0.0 and later
Information in this document applies to any platform.

Symptoms

The Oracle Data Integrator (ODI) Readiness Check for "Domain Based" upgrade throws the following error in the upgrade log:

... [Framework] [ERROR] [UPGAST-00289] [upgrade.Framework] ... Plugin ODI.ODI1 disabled, isUpgradeRequired returned exception.
... [Framework] [ERROR] [] [upgrade.Framework] ... Cause: The plugin threw an exception while processing the request to determine if it has schemas within the domain to upgrade.
... [Framework] [ERROR] [] [upgrade.Framework] ... Action: Contact My Oracle Support.
... [Framework] [ERROR] [] [upgrade.Framework] ... [[
java.util.NoSuchElementException
    at java.util.StringTokenizer.nextToken(StringTokenizer.java:349)
    at oracle.ias.update.plugin.odi.ODIPlugin.isUpgradeRequired(ODIPlugin.java:1493)
    at oracle.ias.update.plugin.Plugin.isUpgradeRequired(Plugin.java:438)
    at oracle.ias.update.wls.WLSEnvironment.isComponentConfiguredInDomain(WLSEnvironment.java:926)

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.