My Oracle Support Banner

DBAT Connector Scheduled Jobs Fail With Error "java.lang.UnsupportedOperationException: Java Runtime Environment (JRE) version 1.7 is not supported by this driver." (Doc ID 2641790.1)

Last updated on FEBRUARY 23, 2020

Applies to:

Identity Manager Connector - Version 9.0.3.1.0 and later
Identity Manager - Version 11.1.2.1.0 to 11.1.2.1.9 [Release 11g]
Information in this document applies to any platform.

Goal

After upgrading the JDK for OIM server from jrockit 1.6.0_37 to JDK 1.7.0_80, the DBAT Connector 9.1.0.5.0 scheduled jobs are failing with the following error when used with Microsoft SQL Server as the target system.


From the error, it seems like the JDBC4.1 jar (sqljdbc41.jar) is required, but it's not clear where you need to copy this jar.

Solution

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.