My Oracle Support Banner

First SALT Webservice Outbound Call From Iseries Tuxedo host To Linux Tuxedo Host Via GWTDOMAIN Fails with "400 Bad Request" (Doc ID 2658587.1)

Last updated on MAY 12, 2021

Applies to:

Oracle Tuxedo - Version 12.1.3 and later
Information in this document applies to any platform.

Symptoms

In Tuxedo environment where the two domains connected

- One is running on IBM iSeries with Tuxedo v-11.1.1.2 and
- The other running on Linux with Tuxedo v 12.1.3


Always, after a restart of Linux/Tuxedo (12.1.3), the first call of any webservice (outbound) from Iseries/Tuxedo(11.1.1.2) --to-> Linux/Tuxedo(12.1.3) FAILS.

In the first call, the Linux/Tuxedo(12.1.3) receives a rare (invalid) characters, however when checked from the origin iSeries/Tuxedo (11.1.1.2) the character messages sent were correctly, not rare (invalid) characters.

However, after repeating call for second time, the 2nd call to webservice (outbound) from Iseries/Tuxedo(11.1.1.2) --to-> Linux/Tuxedo(12.1.3) works CORRECT.

ERROR
-----------------------
In Tuxedo 12.1.3 ULOG in Linux side


BUSINESS IMPACT
-----------------------
The issue has the following business impact:
Due to this issue, users's 1st call to webservice (outbound) fails on production environment and looks like webservice (outbound) calls are not working and this behavior does give the service, that expect about Oracle Tuxedo.

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.