My Oracle Support Banner

Perl Binary with Fresh Fusion MIddleware 12.2.1.4.0 Installation on Solaris SPARC64 is Broken, Version Command Returns "Invalid argument" (Doc ID 2666385.1)

Last updated on MAY 11, 2021

Applies to:

Oracle Fusion Middleware - Version 12.2.1.4.0 to 12.2.1.4.0 [Release 12c]
Oracle HTTP Server - Version 12.2.1.4.0 to 12.2.1.4.0 [Release 12c]
Information in this document applies to any platform.

Symptoms


After installation of Fusion Middleware 12.2.1.4.0 on Solaris Sparc the Perl executable will not work. This would affect any Middeware Installation that includes Perl but will typically be used for an HTTP Server installation.

Running the perl -V command fails with invalid argument,

Oracle_Home/perl/bin$ ./perl -V
-bash: ./perl: Invalid argument



Changes

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.