My Oracle Support Banner

如何更新与WebLogic Server 10.3.6和12c捆绑在一起的JDBC和UCP驱动程序 (Doc ID 2672628.1)

Last updated on MARCH 12, 2021

适用于:

JDBC - 版本 11.2.0.3.0 和更高版本
Oracle Fusion Middleware - 版本 11.1.1.6.0 和更高版本
Oracle WebLogic Server - 版本 10.3.6 和更高版本
本文档所含信息适用于所有平台

目标

如何更新与WebLogic Server 10.3.6和12c捆绑在一起的JDBC和UCP驱动程序

本文档描述了客户应如何升级与WebLogic Server 10.3.6和12c版本捆绑在一起的Oracle JDBC和UCP驱动程序,以支持经过认证的Oracle Database 11g和12c版本。

注意:
  • 本文不是指导使用不同驱动程序认证哪些Oracle数据库版本的文档。 本文档中的信息将帮助您更新和维护已安装的JDBC驱动程序,以改善功能并解决连接到任何经过认证的Oracle数据库的问题。 要查看Oracle WebLogic Server认证了哪些Oracle数据库版本,请访问https://www.oracle.com/technetwork/middleware/ias/downloads/fusion-certification-100350.html或My Oracle Support,认证上查看该版本的认证标签。

  • 请注意,认证是使用安装了FMW / WLS的JDBC驱动程序执行的,而不是因为数据库版本较新而用其他Oracle Database Client提供的驱动程序代替了该驱动程序。 对于10.3.6,需要一些修复程序以及仅为WLS构建的额外补丁程序,在12c版本中,安装时会将补丁程序应用于JDBC组件,以及其他建议。 ->提供此信息并对其进行维护是本文档的范围。
  • 在使用自定义应用程序(例如,未部署FMW的应用程序)时,可以更新CLASSPATH来选择所选的JDBC驱动程序文件,而不是使用WLS安装的JDBC thin驱动程序。 对于WLS 10.3.6和DB 12c版本,请参见<Note:1564509.1>。 对于WLS 12c和DB 12.2,请参阅https://blogs.oracle.com/weblogicserver/oracle-database-122-feature-support-with-weblogic-server。


解决方案

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


文档内容
目标
 如何更新与WebLogic Server 10.3.6和12c捆绑在一起的JDBC和UCP驱动程序
解决方案
 快速总结
 10.3.6/12.1.1
 12.1.2.0
 12.1.3.0
 12.2.1.0-12.2.1.2
 12.2.1.3
 12.2.1.4
参考

My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.