My Oracle Support Banner

When Trying to Remove the User Certificate from a Wallet an Error Occurs,"PKI-02003: Unable to load the wallet" (Doc ID 2676786.1)

Last updated on JUNE 02, 2020

Applies to:

Oracle HTTP Server - Version 12.1.3.0.0 and later
Information in this document applies to any platform.

Symptoms

When trying to update an expiring user certificate the command to remove the current certificate is run,

$MIDDLEWARE_HOME/oracle_common/bin/orapki wallet remove -wallet <path> -dn <user_dn> -user_cert -pwd <pwd>

an error occurs.

PKI-02003: Unable to load the wallet at <path>

The wallet directory is correct and contains both ewallet.p12 and cwallet.sso files and they are owned by the correct user. 

The wallet contents can be displayed using

$MIDDLEWARE_HOME/oracle_common/bin/orapki wallet display -wallet <path>

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.