My Oracle Support Banner

Upgrading Opatch Fails with the Error "java.lang.Exception: oracle.sysman.oii.oiif.oiifb.OiifbEndIterateException: com.oracle.cie.gdr.maven.PomException" (Doc ID 2754340.1)

Last updated on FEBRUARY 26, 2021

Applies to:

Oracle WebLogic Server - Version 12.2.1.3.0 and later
Information in this document applies to any platform.

Symptoms

When trying to upgrade Opatch to 13.9.4.2/13.9.4.2.5 it fails with the below errors:

After cleaning up the the below directories and restoring ORACLE_HOME from backup, Opatch upgrade completes without any errors but many files under ORACLE_HOME/OPatch and ORACLE_HOME/oui went missing.

{OH}/OPatch/plugins/maven/*
{OH}/wlserver/plugins/maven/*
{OH}/oracle_common/plugins/maven/*

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.