My Oracle Support Banner

Oracle Access Manager (OAM) Federation - Service Provider (SP) Initiated SSO Not Working After Accessing WebGate Protected Page "System Error" (Doc ID 2808976.1)

Last updated on SEPTEMBER 28, 2021

Applies to:

Oracle Access Manager - Version 12.2.1.3.0 and later
Information in this document applies to any platform.

Symptoms

Service Provider (SP) Initiated SSO Not Working After Accessing WebGate Protected Page "System Error"

Steps to Reproduce

1. User access WebGate protected resource and user got OAM SSO login page.

Custom login page and it contains "Sign with SSO" link.

2. Instead of entering credentials, user does SP-initiated SSO ( For example, http://<FQDN>/oamfed/sp/initiatesso?providerid=SAML_IDP&returnurl=http://<SP_FQDN:PORT>/<RESOURCE>) in same browser tab.

When user click "Sign with SSO", user redirected to login page where user entering email address.

3. User got login page from IDP and enters IDP credential. Upon successful authentication, IDP redirected user to SP with SAML response

Based on email address, custom login page constructs SP initiate SSO URL and redirected to IDP. 

4. SP throws authentication failed now. (System Error)

Upon successful authentication at Identity Provider ( IDP),  the IDP generated SAML , throws error message on the SP side

 

 

 

 

Changes

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.