My Oracle Support Banner

Job Execution Fails Loading Data to JMS Queue with Error "ODI-40216: Error performing update" or "ODI-20009" with "ODI-17587" (Doc ID 2877321.1)

Last updated on JUNE 22, 2022

Applies to:

Oracle Data Integrator - Version 12.2.1.4.0 and later
Information in this document applies to any platform.

Symptoms

When running a job that loads data into JMS Queue, the following error occurs:

Changes

 The environment may have been recently upgraded from a previous ODI version.

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.